Results 1 to 2 of 2
  1. #1
    New Member
    Join Date
    Dec 2013
    Posts
    3
    Location
    West Point MS
    Tractor
    Shibaura SD1643

    Default Lift Problem

    I have a shibaura sd1643. The rear lift started making noise and basicly stopped working. Would only lift very very slowly. Now the noise has stopped and the lift want lift at all. I finally found the pump and filter. The filter was very dirty so I cleaned it and inspected pump. Put back togeather but still nothing. Would it be any thing other than the pump being bad?

  2. #2
    Veteran Member Kernopelli's Avatar
    Join Date
    Oct 2006
    Posts
    1,680
    Location
    Carterville, Illinois
    Tractor
    Mitsubishi MTE2000D, Dig It 258 Backhoe

    Default Re: Lift Problem

    Could be seals on the lift piston or a partially open relief vale.
    Darryl

Similar Threads

  1. lift problem
    By 261 in forum Hydraulics
    Replies: 2
    Last Post: 04-24-2013, 01:16 PM
  2. 3-Point Hitch 3 pt. lift problem
    By Gurney1010 in forum John Deere Owning/Operating
    Replies: 0
    Last Post: 04-15-2013, 01:18 PM
  3. lift problem
    By jrboatwr in forum Massey Ferguson Owning/Operating
    Replies: 6
    Last Post: 08-07-2011, 04:01 PM
  4. 3 pt lift problem
    By MillWeld in forum Hydraulics
    Replies: 1
    Last Post: 04-23-2011, 07:51 AM
  5. 3-Point Hitch Lift problem
    By loy44 in forum Kubota Owning/Operating
    Replies: 0
    Last Post: 03-08-2010, 05:44 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
© 2014 TractorByNet.com. TractorByNet is a registered trademark of IMC Digital Universe, Inc. Other trademarks on this page are the property of their respective owners.