Results 1 to 3 of 3
  1. #1
    New Member
    Join Date
    Feb 2015
    Posts
    1
    Location
    So. Cal
    Tractor
    TYM

    Default TYM T273 FEL issues

    Hi all. I am new to this site and after scrolling through the previous posts I was unable to find the answer to my question. I have a 273 right now with a FEL and backhoe attachment approximately 500 hrs. The tractor I recently got as an upgrade from a family member from my previous 273 with I backhoe. My question is the FEL on my new 273 works well at high RPM but at idle it will not even lift a bag of feathers whereas my previous 273 the loader had more than enough power at idle I rarely had too increase rpm to lift anything. Has anyone had this problem or is it common since the tractor has the backhoe attachment? Anyone have any solutions? Trying to fix myself since the dealer closest to me is no longer open so the closest dealer is now 300mi north.
    Thanks to all in advance

  2. #2
    Bronze Member
    Join Date
    Oct 2014
    Posts
    51
    Location
    Edgewood, NM
    Tractor
    2002 Scotts L2048 and 2010 TYM T293

    Default Re: TYM T273 FEL issues

    I have a T293 but is almost the same thing as your 273. I have to throttle up a bit to get any lifting from the FEL. It will lift at idle but not if there is much weight on it.

  3. #3
    New Member
    Join Date
    Apr 2015
    Posts
    2
    Location
    Queensland
    Tractor
    tym 273

    Default Re: TYM T273 FEL issues

    Quote Originally Posted by Travis5519 View Post
    Hi all. I am new to this site and after scrolling through the previous posts I was unable to find the answer to my question. I have a 273 right now with a FEL and backhoe attachment approximately 500 hrs. The tractor I recently got as an upgrade from a family member from my previous 273 with I backhoe. My question is the FEL on my new 273 works well at high RPM but at idle it will not even lift a bag of feathers whereas my previous 273 the loader had more than enough power at idle I rarely had too increase rpm to lift anything. Has anyone had this problem or is it common since the tractor has the backhoe attachment? Anyone have any solutions? Trying to fix myself since the dealer closest to me is no longer open so the closest dealer is now 300mi north.
    Thanks to all in advance
    Hi Travis.
    Quick suggestion,
    1) check to see if you have the correct amount of oil in the system,
    2) it may need bleeding.
    3) Cycle through all the movements of the FEL.

    Sometimes the hydraulic spool valves get clogged or stuck, I would think it's a simple fix, as a rule the hydraulic systems rarely have issues and if they do it's generally related to low pressure.

Similar Threads

  1. TYM T273 HST brake switch issues
    By Samberg in forum TYM Owning/Operating
    Replies: 14
    Last Post: 08-20-2014, 11:33 PM
  2. TYM T273 tractor owner
    By Stuart Fields in forum TYM Owning/Operating
    Replies: 0
    Last Post: 09-19-2010, 07:14 PM
  3. TYM T273
    By Tractor Shopper in forum TYM Owning/Operating
    Replies: 4
    Last Post: 01-30-2010, 10:17 AM
  4. looking at a tym t273
    By chrisdvorak in forum Buying/Pricing/Comparisons
    Replies: 2
    Last Post: 08-13-2009, 09:19 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
© 2016 TractorByNet.com. TractorByNet is a registered trademark of IMC Digital Universe, Inc. Other trademarks on this page are the property of their respective owners.