Page 3 of 3 FirstFirst 123
Results 21 to 24 of 24
  1. #21
    Member
    Join Date
    Oct 2008
    Posts
    31
    Location
    Richmond, VA

    Default Re: Yanmar 1500D Engine Runs Full Speed

    OK it was a stuck governer rack in the pump. I didn't know what a governer rack was until I got the pump out and saw it. WD 40 and a rubber hammer freed it up. The pump is back in but the "keeper" pin is difficult to get back in place. I will take some needle nose pliers that have bent end back to help reinstall the pin. Any other suggestions on getting the pin back in with out dropping it into the void behind the pump? Ths pin fits through the shaft that is on the governor rack.

  2. #22
    Member
    Join Date
    Oct 2008
    Posts
    31
    Location
    Richmond, VA

    Default Re: Yanmar 1500D Engine Runs Full Speed

    I was at my lake house this weekend and put the pin back where it belonged in the linkage to the governor rack in the access port that has the breather hose on it. I hooked a thin wire around the pin before trying to install it so that if I dropped it I would not have to remove the pump to hopefully retrieve it from inside the block. Then I grabbed the pin with straight forceps that were 5” long the kind with the ratchet hold close. (I think 8” curved forceps would have been better but I could not find them locally.) The 5” forceps worked well and the pin went right in. I then removed the safety wire I had installed and then unlocked the forceps releasing the pin. After my usual routine of bleeding the air cock on the injector pump while cranking then closing, removing the injectors from the top of the engine and cranking until a solid stream of fuel then reinstalling the injector then bleeding the air out of the air bleed cocks on the top of the cylinders while cranking then closing. She stared right up.

    The culprit that started this 1-1/2 year fix was the throw out bearing that was installed without a carrier (previous owner) which caused lots of smoke, lots of high pitched squeals, and a lock up of the clutch, After the tractor split and a new clutch, clutch plate and installing a new bearing with a new carrier and solving the run-away problem, my Yanmar 1500D runs well and the drive train works great.

    Thanks for all the help from the Forum.

  3. #23
    Super Member clemsonfor's Avatar
    Join Date
    Sep 2009
    Posts
    6,372
    Location
    Greenwood Co., SC
    Tractor
    Yanmar YM2000

    Default Re: Yanmar 1500D Engine Runs Full Speed

    Wow that seemed like a lot of work!

    But you should not have to remove injectors to bleed it. When i change the filter i just do the 2 screw on the filter housing then the one at the pump once all air is out there there should not be any air anywhere else in the sysetem, and if there is you can just loosen the line on the injectors.
    YM2000. MF dirt scoop,4' Jbar bushhog,boompole, LMC 12-16 disk harrow, 4' Atlas boxblade (with rippers). 1980 chevy K10,1990 ford ranger 2wd (285K miles),1997 saturn SL2 (twin cam!!),2001Toyota Higlander
    1986 Cobia 177 sunskiff w/1981 Johnson 60 hp
    1991 Javalen 17ft w/same year 150 Johnson GT
    Troybuilt 4 cycle & Echo 2 stroke,cold natured(need carb rebuild),MS390 Stihl, Northern tool pressure washer, mixes water into the oil in the pump(now dead, motor on a tiller). 5000 watt generator.

  4. #24
    Elite Member
    Join Date
    Dec 2009
    Posts
    2,707
    Location
    gilmer tx
    Tractor
    yanmar 2002d

    Default Re: Yanmar 1500D Engine Runs Full Speed

    Glad to hear you are up and running.

Page 3 of 3 FirstFirst 123

Similar Threads

  1. Replies: 11
    Last Post: 11-24-2013, 11:13 AM
  2. yanmar 1500d repair manual engine 2tr15
    By mica in forum Yanmar
    Replies: 3
    Last Post: 07-17-2012, 10:02 AM
  3. 8n only runs with full choke
    By fibrostic in forum Parts/Repairs
    Replies: 36
    Last Post: 01-24-2012, 01:50 PM
  4. HELP! ENGINE SPEED RUNS AWAY
    By YM2010 in forum Yanmar
    Replies: 9
    Last Post: 11-27-2007, 06:46 PM
  5. BX1500 - Runs rough at full throttle!
    By DaveInColorado in forum Kubota Owning/Operating
    Replies: 33
    Last Post: 06-07-2004, 10:52 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
© 2014 TractorByNet.com. TractorByNet is a registered trademark of IMC Digital Universe, Inc. Other trademarks on this page are the property of their respective owners.