Page 1 of 4 1234 LastLast
Results 1 to 10 of 40
  1. #1
    Member
    Join Date
    Nov 2004
    Posts
    38
    Location
    Sanibel, FL
    Tractor
    YM2200

    Default 3 Point Lift problem...still

    Hello all-
    I am paying for not doing my homework and buying a VN orphan YM2200. Persistent problem with 3 pt lift being weak (wont fully lift my 5' brush hog) when oil is hot. Seems better when cold. FEL seems to be OK, I cannot tell a difference when hot or cold. Have completely changed oil, cleaned screen, replaced internal hydraulic ram with a tested used unit, then got the seals in it replaced (2 1/2 months) figuring the test was done with cold oil. No improvement. Implement will stay up when engine is shut down, suggesting no internal leaking. Lever linkage seems to be OK. Knobs under seat are properly adjusted. Used to work fine, so I assume FEL is plumbed appropriately.
    Now what? I am wondering if it is the hydraulic pump, maybe just not putting out enough pressure and my 3 pt lift needs more than the FEL? Any way of testing it short of buying a new one? Any other parts or areas I ought to check?
    John Churchill

  2. #2
    Member
    Join Date
    Nov 2004
    Posts
    38
    Location
    Sanibel, FL
    Tractor
    YM2200

    Default 3 Point Lift problem...still

    Hello all-
    I am paying for not doing my homework and buying a VN orphan YM2200. Persistent problem with 3 pt lift being weak (wont fully lift my 5' brush hog) when oil is hot. Seems better when cold. FEL seems to be OK, I cannot tell a difference when hot or cold. Have completely changed oil, cleaned screen, replaced internal hydraulic ram with a tested used unit, then got the seals in it replaced (2 1/2 months) figuring the test was done with cold oil. No improvement. Implement will stay up when engine is shut down, suggesting no internal leaking. Lever linkage seems to be OK. Knobs under seat are properly adjusted. Used to work fine, so I assume FEL is plumbed appropriately.
    Now what? I am wondering if it is the hydraulic pump, maybe just not putting out enough pressure and my 3 pt lift needs more than the FEL? Any way of testing it short of buying a new one? Any other parts or areas I ought to check?
    John Churchill

  3. #3
    Veteran Member
    Join Date
    Apr 2002
    Posts
    2,086
    Location
    SW Ohio
    Tractor
    yanmar

    Default Re: 3 Point Lift problem...still

    </font><font color="blue" class="small">( Persistent problem with 3 pt lift being weak )</font>

    </font><font color="blue" class="small">( Used to work fine )</font>

    Somwhere between those two points something changed. Did something happen to the unit that you know of? Anything? Any service, or changes of any kind?

    If it weren't for "used to work fine" I would suggest incorrect fluid.

  4. #4
    Veteran Member
    Join Date
    Apr 2002
    Posts
    2,086
    Location
    SW Ohio
    Tractor
    yanmar

    Default Re: 3 Point Lift problem...still

    </font><font color="blue" class="small">( Persistent problem with 3 pt lift being weak )</font>

    </font><font color="blue" class="small">( Used to work fine )</font>

    Somwhere between those two points something changed. Did something happen to the unit that you know of? Anything? Any service, or changes of any kind?

    If it weren't for "used to work fine" I would suggest incorrect fluid.

  5. #5
    Member
    Join Date
    Nov 2004
    Posts
    38
    Location
    Sanibel, FL
    Tractor
    YM2200

    Default Re: 3 Point Lift problem...still

    I put all new JD 303 hydraulic fluid in it. The thing seemed to be fine when I bought it, then a year later started getting bad after a friend used it to pull some stumps. Do not know exactly what he might have done to it. It then gradually weakened to where it would not work at all, so I am actually better now than before, but still not at full capacity.
    John

  6. #6
    Member
    Join Date
    Nov 2004
    Posts
    38
    Location
    Sanibel, FL
    Tractor
    YM2200

    Default Re: 3 Point Lift problem...still

    I put all new JD 303 hydraulic fluid in it. The thing seemed to be fine when I bought it, then a year later started getting bad after a friend used it to pull some stumps. Do not know exactly what he might have done to it. It then gradually weakened to where it would not work at all, so I am actually better now than before, but still not at full capacity.
    John

  7. #7
    Platinum Member
    Join Date
    Mar 2002
    Posts
    505
    Location
    Tennessee

    Default Re: 3 Point Lift problem...still

    I've only seen a couple dozen of these but it seems there is a (pressure) adjustment when you have the (3pt)valve body off. It has to be in that vincinity since the loader it working.

  8. #8
    Platinum Member
    Join Date
    Mar 2002
    Posts
    505
    Location
    Tennessee

    Default Re: 3 Point Lift problem...still

    I've only seen a couple dozen of these but it seems there is a (pressure) adjustment when you have the (3pt)valve body off. It has to be in that vincinity since the loader it working.

  9. #9
    Gold Member
    Join Date
    Mar 2005
    Posts
    254
    Location
    Talladega county, Sylacauga, AL
    Tractor
    Yanmar YM2020D Satoh Beaver III Yanmar 1500

    Default Re: 3 Point Lift problem...still

    Presure relief valve?

  10. #10
    Gold Member
    Join Date
    Mar 2005
    Posts
    254
    Location
    Talladega county, Sylacauga, AL
    Tractor
    Yanmar YM2020D Satoh Beaver III Yanmar 1500

    Default Re: 3 Point Lift problem...still

    Presure relief valve?

Page 1 of 4 1234 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
© 2014 TractorByNet.com. TractorByNet is a registered trademark of IMC Digital Universe, Inc. Other trademarks on this page are the property of their respective owners.