Cub Cadet Challenger 550

   #1  

DB Pilot

Gold Member
Joined
Feb 1, 2013
Messages
294
Location
SW, New York
Tractor
David Brown 780 Selectomatic, L3800 Kubota, BX2200 Kubota
Have been having a annoying problem with our 2020 challenger 550 since we bought it last year. Sometimes when shifting into gear either forward or reverse there is a grinding (sounds like a chain slipping) before the machine is fully in gear. I do not find a chain drive system so I assume it is gear driven? Then the gear, belt or chain grabs ahold and the machine jumps ahead or back, but operates just fine after that. Most times it shifts smoothly and works as it should.

We have tried pushing on the brake harder when going from forward to reverse and being very gentle with the gas pedal. That doesn't seem to matter so at random times the problem reoccurs with the passengers feeling a whiplash type surge.

The other problem is half the time you cannot get into park without moving the machine alittle until gears line up better and you can get it into park.

Wondering if any other owners have found these problems or know whats wrong.
 
  
  • Thread Starter
#2  
OP
DB Pilot

DB Pilot

Gold Member
Joined
Feb 1, 2013
Messages
294
Location
SW, New York
Tractor
David Brown 780 Selectomatic, L3800 Kubota, BX2200 Kubota
Spoke with dealers mechanic today and explained that my machine does not go into gear until after the gas pedal is pressed. Again only occasionally. His first response was that this was normal. Also with Polaris utv's as they both are belt driven. This was said in front of another mechanic and their boss. A friend of mine also has a Challenger 550, today he drove mine and experienced the belt slippage. Told me he has never experienced that on his machine. I don't know guess I'll drive it til it breaks!
 
 
Top