Global carrier

   #1  

Swedona

New member
Joined
May 5, 2022
Messages
4
Tractor
5075M
My 540M loader with the global carrier will not latch after changing bucket to forks or back. When you curl the implement back the cam does not hit the linkage to reset the latch. Has any one else had this problem ? And what did you do to fix it?
 
   #2  

workinonit

Veteran Member
Joined
Sep 13, 2020
Messages
1,532
Location
Scranton, SC
Tractor
JD 5090E
You mean it won't latch at all or just won't latch without you manually doing it?
 
  
  • Thread Starter
#3  
OP
S

Swedona

New member
Joined
May 5, 2022
Messages
4
Tractor
5075M
It needs to be manually latched. It’s like the latching cam is about a half inch from contacting the latching rod when the bucket/forks are curled back.
 
   #4  

workinonit

Veteran Member
Joined
Sep 13, 2020
Messages
1,532
Location
Scranton, SC
Tractor
JD 5090E
I haven't had that issue I don't think. Seems last time I changed over I may have had to trip mine by hand but I can't be sure. I will take note next time.
 
   #6  

workinonit

Veteran Member
Joined
Sep 13, 2020
Messages
1,532
Location
Scranton, SC
Tractor
JD 5090E
You don't have dirt or debris between the bucket and loader frame that's holding it off?
 
  
  • Thread Starter
#7  
OP
S

Swedona

New member
Joined
May 5, 2022
Messages
4
Tractor
5075M
It’s only has five hours on it. Not even been in the dirt yet.
 
   #9  

Bavarian

Gold Member
Joined
Nov 8, 2015
Messages
477
Location
Winnipeg
Tractor
JD 6430
You also need to lower the loader down to a certain hight. I have a H340 self leveling.
 
 
Top