Help! IHI is-7fx half machine down! Hydraulics???

   #1  

Bilcon

New member
Joined
Jul 10, 2021
Messages
3
Tractor
IHI is-7fx mini excavator
Hi I recently bought an 2010 ihi is-7fx mini ex that’s having issues.

previous owner said it worked great until it had blown a line, he replaced with another line with plumbing fittings(not tapered) anyways ever since the entire right side of the machine is down. No right joystick, except bucket control(works very slowly) main no function up, and no right drive control. The line that blew was in the left side. I’ve winced replaced it with proper line. There is no humming when using those right hand controls. Just the hydraulic fluid as soon as the machine fires up is cream colour foam(lots of air pockets or moisture)

entire left side of machine works as it should. Entire valve block left and right has pressure but not sure what psi.
B8BB2E80-8683-43E3-86A1-6C807825B678.jpeg
but as for the lines coming out of it, I’m not sure what’s considered adequate flow. But clearly something isn’t right.

many suggestions would be greatly appreciated!!
 
   #2  
Joined
Jun 6, 2021
Messages
25
Tractor
IHI 35J Excavator
Hi I recently bought an 2010 ihi is-7fx mini ex that’s having issues.

previous owner said it worked great until it had blown a line, he replaced with another line with plumbing fittings(not tapered) anyways ever since the entire right side of the machine is down. No right joystick, except bucket control(works very slowly) main no function up, and no right drive control. The line that blew was in the left side. I’ve winced replaced it with proper line. There is no humming when using those right hand controls. Just the hydraulic fluid as soon as the machine fires up is cream colour foam(lots of air pockets or moisture)

entire left side of machine works as it should. Entire valve block left and right has pressure but not sure what psi. View attachment 705360but as for the lines coming out of it, I’m not sure what’s considered adequate flow. But clearly something isn’t right.

many suggestions would be greatly appreciated!!
Have you checked the pressures at manifold. I verify that system is full. Air is out of system. Then check pressures.
 
   #3  

gtbensley

Silver Member
Joined
Mar 17, 2016
Messages
159
Location
NH
Tractor
Kubota B7500, Case CX36B
Foam in the fluid...sounds like it has lots of air in the system.
 
   #4  

Seven Gables

Silver Member
Joined
Jan 30, 2019
Messages
244
Location
Northern lower Michigan
Tractor
jd 5115m , Ford 545D, Kubota M8540, NH t4.105 , Ford 5030, Ford 4830, NH TN 95FA, Volvo EC60E
If the hydraulic fluid is cream colored I would drain it as much as possible and replace with new. This probably won’t solve the current issue but will help prevent new ones. As far as air in system has the main pump got a solid flooded flow from the reservoir? No obstructions in the tank screen? Any leaks in the supply hose , fittings and screw clamps where air could be drawn?
 
  
  • Thread Starter
#5  
OP
B

Bilcon

New member
Joined
Jul 10, 2021
Messages
3
Tractor
IHI is-7fx mini excavator
If the hydraulic fluid is cream colored I would drain it as much as possible and replace with new. This probably won’t solve the current issue but will help prevent new ones. As far as air in system has the main pump got a solid flooded flow from the reservoir? No obstructions in the tank screen? Any leaks in the supply hose , fittings and screw clamps where air could be drawn?
It ended up being a bad Orpheus/pressure/flow set valve in the valve block. I believe that’s what it’s called. I swapped left with right and left the middle one, now machine works but I lost the function of blade.
 
 
Top