My New Holland LB75B starts every time

   #1  

jinman

Epic Contributor, R.I.P.
Joined
Feb 23, 2001
Messages
21,008
Location
Texas - Wise County - Sunset
Tractor
NHTC45D, NH LB75B, Ford Jubilee
I suppose this thread could be considered just braggin', but my LB75B TLB is such a great starting machine that I have to brag on it a bit. It seems that if I let it set for a month or two, it will still crank and start every time. Sometimes it will take a bit longer to start because I think the fuel drains back to the tank from the injector pump, but if I crank, pause, an crank again, it fires right off. Mine is a 2005 I bought with 3700 hours and still has the two batteries that came with it. For a used machine to be so reliable, I'm quite amazed. It has paid for itself several times over and continues to perform very well. The transmission and shuttle shift work flawlessly. I firmly believe that if you find one of these old New Hollands that has a solid IVECO diesel, you'll be happy with it for many years. I sure love mine.:)
 
  
  • Thread Starter
#2  
OP
jinman

jinman

Epic Contributor, R.I.P.
Joined
Feb 23, 2001
Messages
21,008
Location
Texas - Wise County - Sunset
Tractor
NHTC45D, NH LB75B, Ford Jubilee
BTW: The reason I'm so amazed at the starting reliability is that there are no glowplugs or intake heater on this model. Certainly, Texas is not as frigid as some other regions, but the IVECO diesel is still surprising in its ability to start cold. As the engine wears, it may become a challenge, but it sure makes me happy now to climb on this machine and have it start right up.
 
   #3  

chriskep1

New member
Joined
May 18, 2009
Messages
8
I have the same machine and I need batteries. I don't have the old ones. Do you know the dimensions or group size of the batteries. Also could I trouble you for a description or picture of how they are configured? My machine is also a 2005 with 2 battery set up. Thanks
 
   #4  

TractorGuy

Elite Member
Joined
Sep 15, 2013
Messages
4,457
Location
N. FL
Tractor
John Deere 4310 CUT, Ford New Holland 575E Industrial Backhoe, John Deere F725 Front Mount Mower
I need to add a second battery to my 575E. It starts every time in the summer but has to be jumped in the winter.

I would be willing to bet you have glow plugs. Try turning the key just before the start position and see if it doesn't light up a glow plug indicator. It will probably start fine without using them as my tractor does but my 575E does have them. It's a spring loaded area just before start so you have to hold the key in the warm up position.
 
 
Top