Horse behaving badly

   #1  

Hiptfarms

Gold Member
Joined
May 23, 2013
Messages
300
Location
Fairfield County, SC
Tractor
Kubota M6800 with BH FEL, Kubota L4400 HST with FEL, Polaris Ranger, BCS 720
Hello all. I am new to the forum and to my 1981 Horse II. A little backstory: I inherited my tiller from a now deceased neighbor so I cannot ask him if it is tilling true to form ror this area. It was in pretty rough shape when I received it. It hadn't been used for about 20 years. I decided to replace the engine with a greyhound clone I scavenged from my old Husqvarna 650 CRT (which suffered from a second dead transmission) instead of keeping the BS 8 hp because my neighbor wasn't exactly known for good maintenance practices. I also replaced the rotted tires with the ones from my dead Husqvarna. So far, so good. I replaced the belt and the reverse disc and now It runs fairly well. In all honesty I do need to clean the carb on the greyhound because it surges a bit. Anyway I think it is the carb and not the governor because I shortened the spring on the governor and it still surges some. I also need to do some more adjusting on the tiller itself because it won't stay in neutral. It has a bad habit of slipping into forward or reverse when it should stay in neutral. Any suggestions? So far I have to say I'm pretty proud of myself for getting the old girl running - a 40 something year old woman with no real small engine repair experience to speak of. Not too shabby if I say so myself!


My main reason for posting is to ask about the way these tillers perform. The rain finally stopped long enough for me to try to use the Horse today. I carted it to my remote garden in the front end loader of my Kubota M6800. I started it and tried to cultivate for maybe 15-20 minutes. Granted I have quite a few rocks but this thing bucks like a wild bronco. Is this the reason they call them Horses? The soil is pretty tilthy and not compacted. The tiller does need new tines but it really beat me up and Im no scrawny little woman! It jerks strongly when it hits a rock which is pretty frequently. I honestly can say I had better tilling with that old crappy Husqvarna than I did with the Horse today. I wonder if I just need to do more adjustments. Can the severely worn tines be causing this response or was I trying to till too deeply? I'm hoping it just needs some more TLC. Any guidance would be greatly appreciated.

Thanks for any help you guys can give.
 
   #2  

DennisArrow

Platinum Member
Joined
Jul 4, 2003
Messages
766
Location
Sugar Valley, Ga
Tractor
Iseki TL 2300, Kubota RTV, Kubota B7610
First of all, WELCOME ABOARD...........Proud of you that you have gotten as far as you have and that is quite a ways. To me, it sounds like you are trying to go to deep per pass. If this is the first time the soil has been tilled or pretty solid, the thing will tend to jump a bit and perhaps run off with you. Have you got the belts adjusted on the "slow" pully?...........Are you tilling in the "slow" low gear?........That is the shift lever on the outside and it goes toward the down position. You need to adjust that little nylon block that the roller rides on on the engage/neutral/reverse lever.......It is kinda sensitive and I cannot remember what the distance for adjustment is; but the roller should just roll over the lip as it goes down and engages the "forward" motion..........Again.......proud that you have done what you have.......God bless........Dennis
 
   #3  

Loadstar

Platinum Member
Joined
Mar 16, 2012
Messages
791
Location
Evansville, IN
Tractor
Ford 640
You might try replacing the spring vs. Trying to adjust. It probably cost less than postage. I agree with above poster about shallower passes to reduce tiller rides.
 
  
  • Thread Starter
#4  
OP
H

Hiptfarms

Gold Member
Joined
May 23, 2013
Messages
300
Location
Fairfield County, SC
Tractor
Kubota M6800 with BH FEL, Kubota L4400 HST with FEL, Polaris Ranger, BCS 720
Thanks for the replies. DennisArrow you may very well be right about me trying to go too deep on the first few passes. I guess I need to try a bit slower and just go a notch at a time to re-break that ground. The soil there is pretty friable but it has been a few weeks since I last cultivated with my Planet junior push cultivator. I'll be sure to check and make certain I have it set up on the lower, slower pulley. Loadstar I also plan on going ahead and replacing that little spring as well. Thanks for the suggestions. I'll give her another try when the rain slows down.
 
 
Top