1982 5211 PTO selector disconnected

   #1  

tnowacoski

New member
Joined
Feb 8, 2016
Messages
6
Location
Columbia Cross Roads, PA
Tractor
Century 2535
We have a 1982 Zetor 5211 with something broken in the PTO system. The PTO engagement level in the cab seems to no longer be connected to anything. We pulled the seat and transmission cover off but there is nothing obvious and we are not sure where to go from there.

Does anyone have a PTO diagram or pointer for us?

If we can even just manually set it into PTO mode and leave it, we can use to clutch to disengage the PTO when necessary.
 
   #2  

Bayfisher

Bronze Member
Joined
Mar 6, 2019
Messages
69
Location
Ms Gulf Coast
Tractor
Zetor 5211
going from memory here, if not mistaken the output shaft at rear of tractor is engaged with the
vertical shaft @ rear of trans, looks like output shaft if the plastic cover is missing which most are,
its just forward of the seat pan.
 
  
  • Thread Starter
#3  
OP
T

tnowacoski

New member
Joined
Feb 8, 2016
Messages
6
Location
Columbia Cross Roads, PA
Tractor
Century 2535
Clarification. The PTO/Hydrualic engage lever is where I am having trouble. Something under the top transmission cover is disconnected. Right now it is in neutral so I have no PTO or 3pt hydraulics. Best case, I would like to find and fix the problem. Worst case, manually shift it to hydraulic & PTO on and use the clutch to disengage when necessary.
 
   #4  

Bayfisher

Bronze Member
Joined
Mar 6, 2019
Messages
69
Location
Ms Gulf Coast
Tractor
Zetor 5211
if u feel everything above the trans cover is in the correct position then u will need to pull
up the trans cover to identify the problem, if u don't have a parts and service manual then get one.
 
   #5  

Agvg

Veteran Member
Joined
May 25, 2013
Messages
2,363
Location
Norway
Tractor
Mf135, Ursus C-355, David Brown 995
A quite common cause for this on Zetors are that the pln that locks the PTO leveler to the shaft breakes and it just moves on the shaft.
 
 
Top