Hard starting 2400H - lift pump failing?

   / Hard starting 2400H - lift pump failing? #1  

oldnslo

Super Member
Joined
Jan 20, 2010
Messages
7,033
Location
Northern, IL
Tractor
Branson 2400H, JD X540
My 2400H has developed problem where it is very hard to get started when engine is at ambient temps of 30 - 50 degrees F. It will crank and sputter and then finally start and run rough like on two cylinders for several seconds before firing on all three. This was a pretty sudden change since used to start fairly easy.

Things I have checked:
Replaced fuel filter. No water or strange substances in fuel filter
Triple checked glow plugs to confirm resistance was similar on all of them
verified getting 12 volts to the glow plugs
Battery is good and turns engine over at decent speed

Fuel flow path is: Gravity feed from fuel tank to filter inlet, filter outlet to mechanical lift pump, lift pump feeds main injector pump.

Question: Would a failing lift or feed pump cause this? Per engine manual lift only provides 3 - 5 PSI. Seems like this would be common element that could cause low fuel flow to the main injector pump and once engine is running possibly supply adequate flow to keep it running. Have not worked engine hard since this problem started but seems to run fine once started.

There is no room between lift pump and main injector pump to install a gauge to confirm pressure.
 
   / Hard starting 2400H - lift pump failing? #2  
Don't know the age of your machine, but have you checked all fuel lines for cracking or poor connections? Sucking air could account for the starting issues you describe,
 
   / Hard starting 2400H - lift pump failing?
  • Thread Starter
#3  
If I remember correctly is either 2013 or 2014 with approx 800 hrs on the clock. Lines do not look cracked but will look again and potentially just change them since that removes another variable.
 
   / Hard starting 2400H - lift pump failing? #4  
Do you hear the lift pump clicking?
 
   / Hard starting 2400H - lift pump failing? #5  
Did you change fuel brand or type recently? I ask because I switched to "renewable" diesel recently and I notice that it starts easily on all cylinders when it's < 50 degrees like it used to when it was new. The last few years it's often started on a couple with the rest joining in within a couple seconds. Going from no biodiesel in the fuel to some might make it start worse.
 
   / Hard starting 2400H - lift pump failing?
  • Thread Starter
#7  
Did you change fuel brand or type recently? I ask because I switched to "renewable" diesel recently and I notice that it starts easily on all cylinders when it's < 50 degrees like it used to when it was new. The last few years it's often started on a couple with the rest joining in within a couple seconds. Going from no biodiesel in the fuel to some might make it start worse.
Bought fuel from same place only difference might be winter blend vs summer. I believe problem was present before filled fuel barrel but do not remember for sure.
 
   / Hard starting 2400H - lift pump failing? #8  
With my hearing loss I do not hear anything but normal diesel engine sounds.
When the key is on(engine not running) the little electric fuel pump should be clicking. If you can’t hear you should be able to feel it with your hand.
 
   / Hard starting 2400H - lift pump failing?
  • Thread Starter
#9  
When the key is on(engine not running) the little electric fuel pump should be clicking. If you can’t hear you should be able to feel it with your hand.
The feed pump is mechanical not electric on this engine.

I did replace fuel line between the filter and and pump and also pulled line from feed pump to main pump to check flow. It seemed to pump decent volume and covering end of hose with thumb it would spray some so could be 3 - 5 PSI. Had air is system so started hard but will let sit and cool off to try it again later.
 
   / Hard starting 2400H - lift pump failing? #10  
The feed pump is mechanical not electric on this engine.

I did replace fuel line between the filter and and pump and also pulled line from feed pump to main pump to check flow. It seemed to pump decent volume and covering end of hose with thumb it would spray some so could be 3 - 5 PSI. Had air is system so started hard but will let sit and cool off to try it again later.
Weird every 2400 I’ve seen had a little electric pump that comes on when the key is on.
 
 
Top